Skip to content

Example: source list translation to interface

r1:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
hostname r1
buggy
!
logging file debug ../binTmp/zzz59r1-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
hostname r2
buggy
!
logging file debug ../binTmp/zzz59r2-log.run
!
access-list test4
 sequence 10 permit all 1.1.1.4 255.255.255.252 all 1.1.1.0 255.255.255.252 all
 exit
!
access-list test6
 sequence 10 permit all 1234:2:: ffff:ffff:: all 1234:1:: ffff:ffff:: all
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 nat v1 sequence 10 srclist test4 interface ethernet1
!
ipv6 nat v1 sequence 10 srclist test6 interface ethernet1
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r3:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
hostname r3
buggy
!
logging file debug ../binTmp/zzz59r3-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 route v1 0.0.0.0 0.0.0.0 1.1.1.5
!
ipv6 route v1 :: :: 1234:2::1
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
r2#
r2#
r2#show ipv4 nat v1 tran
r2#show ipv4 nat v1 tran
 |~~~~~~~|~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~|~~~~~~|
 |       | original                            | translated                          |                                              |
 | proto | source           | target           | source           | target           | age      | last     | timeout  | pack | byte |
 |-------|------------------|------------------|------------------|------------------|----------|----------|----------|------|------|
 | 1     | 1.1.1.1 32359785 | 1.1.1.2 32359785 | 1.1.1.1 32359785 | 1.1.1.6 32359785 | 00:00:02 | 00:00:02 | 00:05:00 | 0    | 0    |
 | 1     | 1.1.1.6 32359785 | 1.1.1.1 32359785 | 1.1.1.2 32359785 | 1.1.1.1 32359785 | 00:00:02 | 00:00:02 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359786 | 1.1.1.2 32359786 | 1.1.1.1 32359786 | 1.1.1.6 32359786 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359786 | 1.1.1.1 32359786 | 1.1.1.2 32359786 | 1.1.1.1 32359786 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359787 | 1.1.1.2 32359787 | 1.1.1.1 32359787 | 1.1.1.6 32359787 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359787 | 1.1.1.1 32359787 | 1.1.1.2 32359787 | 1.1.1.1 32359787 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359788 | 1.1.1.2 32359788 | 1.1.1.1 32359788 | 1.1.1.6 32359788 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359788 | 1.1.1.1 32359788 | 1.1.1.2 32359788 | 1.1.1.1 32359788 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359789 | 1.1.1.2 32359789 | 1.1.1.1 32359789 | 1.1.1.6 32359789 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359789 | 1.1.1.1 32359789 | 1.1.1.2 32359789 | 1.1.1.1 32359789 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359790 | 1.1.1.2 32359790 | 1.1.1.1 32359790 | 1.1.1.6 32359790 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359790 | 1.1.1.1 32359790 | 1.1.1.2 32359790 | 1.1.1.1 32359790 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359791 | 1.1.1.2 32359791 | 1.1.1.1 32359791 | 1.1.1.6 32359791 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359791 | 1.1.1.1 32359791 | 1.1.1.2 32359791 | 1.1.1.1 32359791 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359792 | 1.1.1.2 32359792 | 1.1.1.1 32359792 | 1.1.1.6 32359792 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359792 | 1.1.1.1 32359792 | 1.1.1.2 32359792 | 1.1.1.1 32359792 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 32359793 | 1.1.1.2 32359793 | 1.1.1.1 32359793 | 1.1.1.6 32359793 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 32359793 | 1.1.1.1 32359793 | 1.1.1.2 32359793 | 1.1.1.1 32359793 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 |_______|__________________|__________________|__________________|__________________|__________|__________|__________|______|______|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
r2#
r2#
r2#show ipv6 nat v1 tran
r2#show ipv6 nat v1 tran
 |~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~|~~~~~~|
 |       | original                                  | translated                                |                                              |
 | proto | source              | target              | source              | target              | age      | last     | timeout  | pack | byte |
 |-------|---------------------|---------------------|---------------------|---------------------|----------|----------|----------|------|------|
 | 58    | 1234:1::1 330263772 | 1234:1::2 330263772 | 1234:1::1 330263772 | 1234:2::2 330263772 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 330263772 | 1234:1::1 330263772 | 1234:1::2 330263772 | 1234:1::1 330263772 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 330263773 | 1234:1::2 330263773 | 1234:1::1 330263773 | 1234:2::2 330263773 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 330263773 | 1234:1::1 330263773 | 1234:1::2 330263773 | 1234:1::1 330263773 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 330263774 | 1234:1::2 330263774 | 1234:1::1 330263774 | 1234:2::2 330263774 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 330263774 | 1234:1::1 330263774 | 1234:1::2 330263774 | 1234:1::1 330263774 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 330263775 | 1234:1::2 330263775 | 1234:1::1 330263775 | 1234:2::2 330263775 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 330263775 | 1234:1::1 330263775 | 1234:1::2 330263775 | 1234:1::1 330263775 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 330263776 | 1234:1::2 330263776 | 1234:1::1 330263776 | 1234:2::2 330263776 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 330263776 | 1234:1::1 330263776 | 1234:1::2 330263776 | 1234:1::1 330263776 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 |_______|_____________________|_____________________|_____________________|_____________________|__________|__________|__________|______|______|
r2#
r2#