Skip to content

Example: source list translation to address

r1:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
hostname r1
buggy
!
logging file debug ../binTmp/zzz35r1-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
hostname r2
buggy
!
logging file debug ../binTmp/zzz35r2-log.run
!
access-list test4
 sequence 10 permit all 1.1.1.4 255.255.255.252 all 1.1.1.0 255.255.255.252 all
 exit
!
access-list test6
 sequence 10 permit all 1234:2:: ffff:ffff:: all 1234:1:: ffff:ffff:: all
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 nat v1 sequence 10 srclist test4 1.1.1.2
!
ipv6 nat v1 sequence 10 srclist test6 1234:1::2
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r3:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
hostname r3
buggy
!
logging file debug ../binTmp/zzz35r3-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 route v1 0.0.0.0 0.0.0.0 1.1.1.5
!
ipv6 route v1 :: :: 1234:2::1
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
r2#
r2#
r2#show ipv4 nat v1 tran
r2#show ipv4 nat v1 tran
 |~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~|~~~~~~|
 |       | original                              | translated                            |                                              |
 | proto | source            | target            | source            | target            | age      | last     | timeout  | pack | byte |
 |-------|-------------------|-------------------|-------------------|-------------------|----------|----------|----------|------|------|
 | 1     | 1.1.1.1 703434797 | 1.1.1.2 703434797 | 1.1.1.1 703434797 | 1.1.1.6 703434797 | 00:00:02 | 00:00:02 | 00:05:00 | 0    | 0    |
 | 1     | 1.1.1.6 703434797 | 1.1.1.1 703434797 | 1.1.1.2 703434797 | 1.1.1.1 703434797 | 00:00:02 | 00:00:02 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434798 | 1.1.1.2 703434798 | 1.1.1.1 703434798 | 1.1.1.6 703434798 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434798 | 1.1.1.1 703434798 | 1.1.1.2 703434798 | 1.1.1.1 703434798 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434799 | 1.1.1.2 703434799 | 1.1.1.1 703434799 | 1.1.1.6 703434799 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434799 | 1.1.1.1 703434799 | 1.1.1.2 703434799 | 1.1.1.1 703434799 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434800 | 1.1.1.2 703434800 | 1.1.1.1 703434800 | 1.1.1.6 703434800 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434800 | 1.1.1.1 703434800 | 1.1.1.2 703434800 | 1.1.1.1 703434800 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434801 | 1.1.1.2 703434801 | 1.1.1.1 703434801 | 1.1.1.6 703434801 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434801 | 1.1.1.1 703434801 | 1.1.1.2 703434801 | 1.1.1.1 703434801 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434802 | 1.1.1.2 703434802 | 1.1.1.1 703434802 | 1.1.1.6 703434802 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434802 | 1.1.1.1 703434802 | 1.1.1.2 703434802 | 1.1.1.1 703434802 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434803 | 1.1.1.2 703434803 | 1.1.1.1 703434803 | 1.1.1.6 703434803 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434803 | 1.1.1.1 703434803 | 1.1.1.2 703434803 | 1.1.1.1 703434803 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434804 | 1.1.1.2 703434804 | 1.1.1.1 703434804 | 1.1.1.6 703434804 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434804 | 1.1.1.1 703434804 | 1.1.1.2 703434804 | 1.1.1.1 703434804 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 703434805 | 1.1.1.2 703434805 | 1.1.1.1 703434805 | 1.1.1.6 703434805 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.6 703434805 | 1.1.1.1 703434805 | 1.1.1.2 703434805 | 1.1.1.1 703434805 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 |_______|___________________|___________________|___________________|___________________|__________|__________|__________|______|______|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
r2#
r2#
r2#show ipv6 nat v1 tran
r2#show ipv6 nat v1 tran
 |~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~|~~~~~~|
 |       | original                                  | translated                                |                                              |
 | proto | source              | target              | source              | target              | age      | last     | timeout  | pack | byte |
 |-------|---------------------|---------------------|---------------------|---------------------|----------|----------|----------|------|------|
 | 58    | 1234:1::1 666122417 | 1234:1::2 666122417 | 1234:1::1 666122417 | 1234:2::2 666122417 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 666122417 | 1234:1::1 666122417 | 1234:1::2 666122417 | 1234:1::1 666122417 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 666122418 | 1234:1::2 666122418 | 1234:1::1 666122418 | 1234:2::2 666122418 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 666122418 | 1234:1::1 666122418 | 1234:1::2 666122418 | 1234:1::1 666122418 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 666122419 | 1234:1::2 666122419 | 1234:1::1 666122419 | 1234:2::2 666122419 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 666122419 | 1234:1::1 666122419 | 1234:1::2 666122419 | 1234:1::1 666122419 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 666122420 | 1234:1::2 666122420 | 1234:1::1 666122420 | 1234:2::2 666122420 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 666122420 | 1234:1::1 666122420 | 1234:1::2 666122420 | 1234:1::1 666122420 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 666122421 | 1234:1::2 666122421 | 1234:1::1 666122421 | 1234:2::2 666122421 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:2::2 666122421 | 1234:1::1 666122421 | 1234:1::2 666122421 | 1234:1::1 666122421 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 |_______|_____________________|_____________________|_____________________|_____________________|__________|__________|__________|______|______|
r2#
r2#