Skip to content

Example: source address translation to address

r1:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
hostname r1
buggy
!
logging file debug ../binTmp/zzz55r1-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
hostname r2
buggy
!
logging file debug ../binTmp/zzz55r2-log.run
!
access-list test4
 sequence 10 permit all 1.1.1.4 255.255.255.252 all 1.1.1.0 255.255.255.252 all
 exit
!
access-list test6
 sequence 10 permit all 1234:2:: ffff:ffff:: all 1234:1:: ffff:ffff:: all
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 route v1 8.8.8.8 255.255.255.255 1.1.1.6
!
ipv6 route v1 8888::8 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff 1234:2::2
!
!
!
ipv4 nat v1 sequence 10 source 8.8.8.8 1.1.1.2
!
ipv6 nat v1 sequence 10 source 8888::8 1234:1::2
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r3:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
hostname r3
buggy
!
logging file debug ../binTmp/zzz55r3-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 8.8.8.8 255.255.255.255
 ipv6 address 8888::8 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 route v1 0.0.0.0 0.0.0.0 1.1.1.5
!
ipv6 route v1 :: :: 1234:2::1
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
r2#
r2#
r2#show ipv4 nat v1 tran
r2#show ipv4 nat v1 tran
 |~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~|~~~~~~|
 |       | original                              | translated                            |                                              |
 | proto | source            | target            | source            | target            | age      | last     | timeout  | pack | byte |
 |-------|-------------------|-------------------|-------------------|-------------------|----------|----------|----------|------|------|
 | 1     | 1.1.1.1 420337626 | 1.1.1.2 420337626 | 1.1.1.1 420337626 | 8.8.8.8 420337626 | 00:00:05 | 00:00:05 | 00:05:00 | 0    | 0    |
 | 1     | 8.8.8.8 420337626 | 1.1.1.1 420337626 | 1.1.1.2 420337626 | 1.1.1.1 420337626 | 00:00:05 | 00:00:05 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337627 | 1.1.1.2 420337627 | 1.1.1.1 420337627 | 8.8.8.8 420337627 | 00:00:04 | 00:00:04 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337627 | 1.1.1.1 420337627 | 1.1.1.2 420337627 | 1.1.1.1 420337627 | 00:00:04 | 00:00:04 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337628 | 1.1.1.2 420337628 | 1.1.1.1 420337628 | 8.8.8.8 420337628 | 00:00:04 | 00:00:04 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337628 | 1.1.1.1 420337628 | 1.1.1.2 420337628 | 1.1.1.1 420337628 | 00:00:04 | 00:00:04 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337629 | 1.1.1.2 420337629 | 1.1.1.1 420337629 | 8.8.8.8 420337629 | 00:00:04 | 00:00:04 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337629 | 1.1.1.1 420337629 | 1.1.1.2 420337629 | 1.1.1.1 420337629 | 00:00:04 | 00:00:04 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337630 | 1.1.1.2 420337630 | 1.1.1.1 420337630 | 8.8.8.8 420337630 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337630 | 1.1.1.1 420337630 | 1.1.1.2 420337630 | 1.1.1.1 420337630 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337631 | 1.1.1.2 420337631 | 1.1.1.1 420337631 | 8.8.8.8 420337631 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337631 | 1.1.1.1 420337631 | 1.1.1.2 420337631 | 1.1.1.1 420337631 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337632 | 1.1.1.2 420337632 | 1.1.1.1 420337632 | 8.8.8.8 420337632 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337632 | 1.1.1.1 420337632 | 1.1.1.2 420337632 | 1.1.1.1 420337632 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337633 | 1.1.1.2 420337633 | 1.1.1.1 420337633 | 8.8.8.8 420337633 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337633 | 1.1.1.1 420337633 | 1.1.1.2 420337633 | 1.1.1.1 420337633 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 1.1.1.1 420337634 | 1.1.1.2 420337634 | 1.1.1.1 420337634 | 8.8.8.8 420337634 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 1     | 8.8.8.8 420337634 | 1.1.1.1 420337634 | 1.1.1.2 420337634 | 1.1.1.1 420337634 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 |_______|___________________|___________________|___________________|___________________|__________|__________|__________|______|______|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
r2#
r2#
r2#show ipv6 nat v1 tran
r2#show ipv6 nat v1 tran
 |~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~|~~~~~~|
 |       | original                                  | translated                                |                                              |
 | proto | source              | target              | source              | target              | age      | last     | timeout  | pack | byte |
 |-------|---------------------|---------------------|---------------------|---------------------|----------|----------|----------|------|------|
 | 58    | 1234:1::1 757744154 | 1234:1::2 757744154 | 1234:1::1 757744154 | 8888::8 757744154   | 00:00:03 | 00:00:03 | 00:05:00 | 0    | 0    |
 | 58    | 8888::8 757744154   | 1234:1::1 757744154 | 1234:1::2 757744154 | 1234:1::1 757744154 | 00:00:03 | 00:00:03 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744155 | 1234:1::2 757744155 | 1234:1::1 757744155 | 8888::8 757744155   | 00:00:02 | 00:00:02 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744155   | 1234:1::1 757744155 | 1234:1::2 757744155 | 1234:1::1 757744155 | 00:00:02 | 00:00:02 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744156 | 1234:1::2 757744156 | 1234:1::1 757744156 | 8888::8 757744156   | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744156   | 1234:1::1 757744156 | 1234:1::2 757744156 | 1234:1::1 757744156 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744157 | 1234:1::2 757744157 | 1234:1::1 757744157 | 8888::8 757744157   | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744157   | 1234:1::1 757744157 | 1234:1::2 757744157 | 1234:1::1 757744157 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744158 | 1234:1::2 757744158 | 1234:1::1 757744158 | 8888::8 757744158   | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744158   | 1234:1::1 757744158 | 1234:1::2 757744158 | 1234:1::1 757744158 | 00:00:01 | 00:00:01 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744159 | 1234:1::2 757744159 | 1234:1::1 757744159 | 8888::8 757744159   | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744159   | 1234:1::1 757744159 | 1234:1::2 757744159 | 1234:1::1 757744159 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744160 | 1234:1::2 757744160 | 1234:1::1 757744160 | 8888::8 757744160   | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744160   | 1234:1::1 757744160 | 1234:1::2 757744160 | 1234:1::1 757744160 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744161 | 1234:1::2 757744161 | 1234:1::1 757744161 | 8888::8 757744161   | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744161   | 1234:1::1 757744161 | 1234:1::2 757744161 | 1234:1::1 757744161 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744162 | 1234:1::2 757744162 | 1234:1::1 757744162 | 8888::8 757744162   | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744162   | 1234:1::1 757744162 | 1234:1::2 757744162 | 1234:1::1 757744162 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 1234:1::1 757744163 | 1234:1::2 757744163 | 1234:1::1 757744163 | 8888::8 757744163   | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 | 58    | 8888::8 757744163   | 1234:1::1 757744163 | 1234:1::2 757744163 | 1234:1::1 757744163 | 00:00:00 | 00:00:00 | 00:05:00 | 1    | 64   |
 |_______|_____________________|_____________________|_____________________|_____________________|__________|__________|__________|______|______|
r2#
r2#