Skip to content

Example: evpn/cmac over srv6 over bgp additional path

r1:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
hostname r1
buggy
!
logging file debug ../binTmp/zzz73r1-log.run
!
bridge 1
 rd 1:1
 rt-import 1:1
 rt-export 1:1
 mac-learn
 private-bridge
 exit
!
bridge 2
 rd 1:2
 rt-import 1:2
 rt-export 1:2
 mac-learn
 private-bridge
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface bvi1
 no description
 vrf forwarding v1
 ipv4 address 3.3.3.1 255.255.255.252
 ipv6 address 3333::1 ffff::
 no shutdown
 no log-link-change
 exit
!
interface bvi2
 no description
 vrf forwarding v1
 ipv4 address 4.4.4.1 255.255.255.252
 ipv6 address 4444::1 ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.0
 ipv6 address 1234::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface tunnel1
 no description
 tunnel vrf v1
 tunnel source ethernet1
 tunnel destination 4321:1::
 tunnel mode srv6
 vrf forwarding v1
 ipv6 address 4321:1:: ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
router bgp4 1
 vrf v1
 local-as 1
 router-id 4.4.4.1
 no safe-ebgp
 address-family evpn
 neighbor 1.1.1.2 remote-as 1
 no neighbor 1.1.1.2 description
 neighbor 1.1.1.2 local-as 1
 neighbor 1.1.1.2 address-family evpn
 neighbor 1.1.1.2 distance 200
 neighbor 1.1.1.2 additional-path-rx evpn
 neighbor 1.1.1.2 additional-path-tx evpn
 neighbor 1.1.1.2 pmsitun
 neighbor 1.1.1.2 segrout
 neighbor 1.1.1.2 send-community standard extended
 afi-evpn 101 bridge-group 1
 afi-evpn 101 srv6 tunnel1
 afi-evpn 101 bmac 0054.7b16.6279
 afi-evpn 101 encapsulation cmac
 afi-evpn 101 update-source ethernet1
 exit
!
router bgp6 1
 vrf v1
 local-as 1
 router-id 6.6.6.1
 no safe-ebgp
 address-family evpn
 neighbor 1234::2 remote-as 1
 no neighbor 1234::2 description
 neighbor 1234::2 local-as 1
 neighbor 1234::2 address-family evpn
 neighbor 1234::2 distance 200
 neighbor 1234::2 additional-path-rx evpn
 neighbor 1234::2 additional-path-tx evpn
 neighbor 1234::2 pmsitun
 neighbor 1234::2 segrout
 neighbor 1234::2 send-community standard extended
 afi-evpn 102 bridge-group 2
 afi-evpn 102 srv6 tunnel1
 afi-evpn 102 bmac 0003.1616.0e17
 afi-evpn 102 encapsulation cmac
 afi-evpn 102 update-source ethernet1
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv6 route v1 4321:2:: ffff:ffff:: 1234::2
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
hostname r2
buggy
!
logging file debug ../binTmp/zzz73r2-log.run
!
bridge 1
 rd 1:1
 rt-import 1:1
 rt-export 1:1
 mac-learn
 private-bridge
 exit
!
bridge 2
 rd 1:2
 rt-import 1:2
 rt-export 1:2
 mac-learn
 private-bridge
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface bvi1
 no description
 vrf forwarding v1
 ipv4 address 3.3.3.2 255.255.255.252
 ipv6 address 3333::2 ffff::
 no shutdown
 no log-link-change
 exit
!
interface bvi2
 no description
 vrf forwarding v1
 ipv4 address 4.4.4.2 255.255.255.252
 ipv6 address 4444::2 ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.0
 ipv6 address 1234::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface tunnel1
 no description
 tunnel vrf v1
 tunnel source ethernet1
 tunnel destination 4321:2::
 tunnel mode srv6
 vrf forwarding v1
 ipv6 address 4321:2:: ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
router bgp4 1
 vrf v1
 local-as 1
 router-id 4.4.4.2
 no safe-ebgp
 address-family evpn
 neighbor 1.1.1.1 remote-as 1
 no neighbor 1.1.1.1 description
 neighbor 1.1.1.1 local-as 1
 neighbor 1.1.1.1 address-family evpn
 neighbor 1.1.1.1 distance 200
 neighbor 1.1.1.1 additional-path-rx evpn
 neighbor 1.1.1.1 additional-path-tx evpn
 neighbor 1.1.1.1 pmsitun
 neighbor 1.1.1.1 segrout
 neighbor 1.1.1.1 send-community standard extended
 afi-evpn 101 bridge-group 1
 afi-evpn 101 srv6 tunnel1
 afi-evpn 101 bmac 007a.2c73.0b3b
 afi-evpn 101 encapsulation cmac
 afi-evpn 101 update-source ethernet1
 exit
!
router bgp6 1
 vrf v1
 local-as 1
 router-id 6.6.6.2
 no safe-ebgp
 address-family evpn
 neighbor 1234::1 remote-as 1
 no neighbor 1234::1 description
 neighbor 1234::1 local-as 1
 neighbor 1234::1 address-family evpn
 neighbor 1234::1 distance 200
 neighbor 1234::1 additional-path-rx evpn
 neighbor 1234::1 additional-path-tx evpn
 neighbor 1234::1 pmsitun
 neighbor 1234::1 segrout
 neighbor 1234::1 send-community standard extended
 afi-evpn 102 bridge-group 2
 afi-evpn 102 srv6 tunnel1
 afi-evpn 102 bmac 0056.2755.4c04
 afi-evpn 102 encapsulation cmac
 afi-evpn 102 update-source ethernet1
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv6 route v1 4321:1:: ffff:ffff:: 1234::1
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end