Skip to content

Example: eigrp address unsuppression

r1:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
hostname r1
buggy
!
logging file debug ../binTmp/zzz16r1-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router eigrp4 1
 vrf v1
 router-id 4.4.4.1
 as 1
 suppress-prefix
 exit
!
router eigrp6 1
 vrf v1
 router-id 6.6.6.1
 as 1
 suppress-prefix
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.1 255.255.255.255
 ipv6 address 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router eigrp4 1 enable
 router eigrp4 1 passive
 router eigrp6 1 enable
 router eigrp6 1 passive
 no shutdown
 no log-link-change
 exit
!
interface loopback2
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.2 255.255.255.255
 ipv6 address 4321::2 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router eigrp4 1 enable
 router eigrp4 1 passive
 router eigrp4 1 unsuppress-prefix
 router eigrp6 1 enable
 router eigrp6 1 passive
 router eigrp6 1 unsuppress-prefix
 no shutdown
 no log-link-change
 exit
!
interface loopback3
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.3 255.255.255.255
 ipv6 address 4321::3 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router eigrp4 1 enable
 router eigrp4 1 passive
 router eigrp6 1 enable
 router eigrp6 1 passive
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 router eigrp4 1 enable
 router eigrp6 1 enable
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
hostname r2
buggy
!
logging file debug ../binTmp/zzz16r2-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router eigrp4 1
 vrf v1
 router-id 4.4.4.2
 as 1
 exit
!
router eigrp6 1
 vrf v1
 router-id 6.6.6.2
 as 1
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.111 255.255.255.255
 ipv6 address 4321::111 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router eigrp4 1 enable
 router eigrp4 1 passive
 router eigrp6 1 enable
 router eigrp6 1 passive
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 router eigrp4 1 enable
 router eigrp6 1 enable
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
r2#
r2#
r2#show ipv4 eigrp 1 sum
r2#show ipv4 eigrp 1 sum
 |~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|
 | iface     | peer    | learned | adverted | uptime   |
 |-----------|---------|---------|----------|----------|
 | ethernet1 | 1.1.1.1 | 1       | 1        | 00:00:16 |
 |___________|_________|_________|__________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
r2#
r2#
r2#show ipv6 eigrp 1 sum
r2#show ipv6 eigrp 1 sum
 |~~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|
 | iface     | peer      | learned | adverted | uptime   |
 |-----------|-----------|---------|----------|----------|
 | ethernet1 | 1234:1::1 | 1       | 1        | 00:00:16 |
 |___________|___________|_________|__________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
r2#
r2#
r2#show ipv4 eigrp 1 rou
r2#show ipv4 eigrp 1 rou
 |~~~~~~|~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|
 | typ  | prefix       | metric | iface     | hop     | time     |
 |------|--------------|--------|-----------|---------|----------|
 | C    | 1.1.1.0/30   | 1/0    | ethernet1 | null    | 00:00:02 |
 | null | 2.2.2.2/32   | 90/10  | ethernet1 | 1.1.1.1 | 00:00:02 |
 | C    | 2.2.2.111/32 | 1/0    | loopback1 | null    | 00:00:02 |
 |______|______________|________|___________|_________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
r2#
r2#
r2#show ipv6 eigrp 1 rou
r2#show ipv6 eigrp 1 rou
 |~~~~~~|~~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|
 | typ  | prefix        | metric | iface     | hop       | time     |
 |------|---------------|--------|-----------|-----------|----------|
 | C    | 1234:1::/32   | 1/0    | ethernet1 | null      | 00:00:02 |
 | null | 4321::2/128   | 90/10  | ethernet1 | 1234:1::1 | 00:00:02 |
 | C    | 4321::111/128 | 1/0    | loopback1 | null      | 00:00:02 |
 |______|_______________|________|___________|___________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
r2#
r2#
r2#show ipv4 route v1
r2#show ipv4 route v1
 |~~~~~|~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|
 | typ | prefix       | metric | iface     | hop     | time     |
 |-----|--------------|--------|-----------|---------|----------|
 | C   | 1.1.1.0/30   | 0/0    | ethernet1 | null    | 00:00:18 |
 | LOC | 1.1.1.2/32   | 0/1    | ethernet1 | null    | 00:00:18 |
 | D   | 2.2.2.2/32   | 90/10  | ethernet1 | 1.1.1.1 | 00:00:02 |
 | C   | 2.2.2.111/32 | 0/0    | loopback1 | null    | 00:00:18 |
 |_____|______________|________|___________|_________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
r2#
r2#
r2#show ipv6 route v1
r2#show ipv6 route v1
 |~~~~~|~~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|
 | typ | prefix        | metric | iface     | hop       | time     |
 |-----|---------------|--------|-----------|-----------|----------|
 | C   | 1234:1::/32   | 0/0    | ethernet1 | null      | 00:00:18 |
 | LOC | 1234:1::2/128 | 0/1    | ethernet1 | null      | 00:00:18 |
 | D   | 4321::2/128   | 90/10  | ethernet1 | 1234:1::1 | 00:00:02 |
 | C   | 4321::111/128 | 0/0    | loopback1 | null      | 00:00:18 |
 |_____|_______________|________|___________|___________|__________|
r2#
r2#