Skip to content

Example: ospf transit area

r1:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
hostname r1
buggy
!
logging file debug ../binTmp/zzz92r1-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router ospf4 1
 vrf v1
 router-id 4.4.4.1
 traffeng-id 0.0.0.0
 area 0 enable
 redistribute connected
 exit
!
router ospf6 1
 vrf v1
 router-id 6.6.6.1
 traffeng-id ::
 area 0 enable
 redistribute connected
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.1 255.255.255.255
 ipv6 address 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf6 1 enable
 router ospf6 1 area 0
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
hostname r2
buggy
!
logging file debug ../binTmp/zzz92r2-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router ospf4 1
 vrf v1
 router-id 4.4.4.2
 traffeng-id 0.0.0.0
 area 0 enable
 area 1 enable
 redistribute connected
 exit
!
router ospf6 1
 vrf v1
 router-id 6.6.6.2
 traffeng-id ::
 area 0 enable
 area 1 enable
 redistribute connected
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.2 255.255.255.255
 ipv6 address 4321::2 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf6 1 enable
 router ospf6 1 area 0
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 router ospf4 1 enable
 router ospf4 1 area 1
 router ospf6 1 enable
 router ospf6 1 area 1
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r3:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
hostname r3
buggy
!
logging file debug ../binTmp/zzz92r3-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router ospf4 1
 vrf v1
 router-id 4.4.4.3
 traffeng-id 0.0.0.0
 area 1 enable
 redistribute connected
 exit
!
router ospf6 1
 vrf v1
 router-id 6.6.6.3
 traffeng-id ::
 area 1 enable
 redistribute connected
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.3 255.255.255.255
 ipv6 address 4321::3 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface loopback2
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.33 255.255.255.255
 ipv6 address 4321::33 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router ospf4 1 enable
 router ospf4 1 area 1
 router ospf4 1 passive
 router ospf6 1 enable
 router ospf6 1 area 1
 router ospf6 1 passive
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 router ospf4 1 enable
 router ospf4 1 area 1
 router ospf6 1 enable
 router ospf6 1 area 1
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r2#
r2#
r2#show ipv4 ospf 1 nei
r2#show ipv4 ospf 1 nei
 |~~~~~~~~~~~|~~~~~~|~~~~~~~~~|~~~~~~~~~~|~~~~~~~|~~~~~~~~~~|
 | interface | area | address | routerid | state | uptime   |
 |-----------|------|---------|----------|-------|----------|
 | ethernet1 | 0    | 1.1.1.1 | 4.4.4.1  | full  | 00:00:05 |
 | ethernet2 | 1    | 1.1.1.6 | 4.4.4.3  | full  | 00:00:05 |
 |___________|______|_________|__________|_______|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r2#
r2#
r2#show ipv6 ospf 1 nei
r2#show ipv6 ospf 1 nei
 |~~~~~~~~~~~|~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~|~~~~~~~~~~|
 | interface | area | address   | routerid | state | uptime   |
 |-----------|------|-----------|----------|-------|----------|
 | ethernet1 | 0    | 1234:1::1 | 6.6.6.1  | full  | 00:00:05 |
 | ethernet2 | 1    | 1234:2::2 | 6.6.6.3  | full  | 00:00:05 |
 |___________|______|___________|__________|_______|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
r2#
r2#
r2#show ipv4 ospf 1 dat 0
r2#show ipv4 ospf 1 dat 0
 |~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~~~~~~~|~~~~~|~~~~~~~~~~|
 | routerid | lsaid    | sequence | type           | len | time     |
 |----------|----------|----------|----------------|-----|----------|
 | 4.4.4.1  | 4.4.4.1  | 80000004 | router         | 28  | 00:00:03 |
 | 4.4.4.2  | 4.4.4.2  | 80000006 | router         | 28  | 00:00:03 |
 | 4.4.4.2  | 1.1.1.4  | 80000001 | summaryNetwork | 8   | 00:00:06 |
 | 4.4.4.2  | 2.2.2.3  | 80000001 | summaryNetwork | 8   | 00:00:02 |
 | 4.4.4.2  | 2.2.2.33 | 80000001 | summaryNetwork | 8   | 00:00:02 |
 | 4.4.4.1  | 0.0.0.0  | 80000002 | asExternal     | 16  | 01:00:07 |
 | 4.4.4.2  | 0.0.0.0  | 80000006 | asExternal     | 16  | 01:00:06 |
 | 4.4.4.1  | 1.1.1.0  | 80000001 | asExternal     | 16  | 00:00:07 |
 | 4.4.4.2  | 1.1.1.0  | 80000001 | asExternal     | 16  | 00:00:06 |
 | 4.4.4.2  | 1.1.1.4  | 80000001 | asExternal     | 16  | 00:00:06 |
 | 4.4.4.1  | 2.2.2.1  | 80000001 | asExternal     | 16  | 00:00:07 |
 | 4.4.4.2  | 2.2.2.2  | 80000001 | asExternal     | 16  | 00:00:06 |
 | 4.4.4.1  | 4.0.0.0  | 80000001 | opaque-area    | 16  | 00:00:07 |
 | 4.4.4.2  | 4.0.0.0  | 80000001 | opaque-area    | 16  | 00:00:06 |
 |__________|__________|__________|________________|_____|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
r2#
r2#
r2#show ipv6 ospf 1 dat 0
r2#show ipv6 ospf 1 dat 0
 |~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~~~|~~~~~|~~~~~~~~~~|
 | routerid | lsaid     | sequence | type       | len | time     |
 |----------|-----------|----------|------------|-----|----------|
 | 6.6.6.1  | 546616411 | 80000001 | link       | 24  | 00:00:07 |
 | 6.6.6.2  | 891222953 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.2  | 891222954 | 80000002 | link       | 24  | 01:00:06 |
 | 6.6.6.1  | 0         | 80000003 | router     | 20  | 00:00:03 |
 | 6.6.6.2  | 0         | 80000004 | router     | 20  | 00:00:03 |
 | 6.6.6.2  | 0         | 80000001 | iaPrefix   | 12  | 00:00:06 |
 | 6.6.6.2  | 1         | 80000001 | iaPrefix   | 24  | 00:00:03 |
 | 6.6.6.2  | 2         | 80000001 | iaPrefix   | 24  | 00:00:03 |
 | 6.6.6.1  | 546616411 | 80000001 | prefix     | 20  | 00:00:07 |
 | 6.6.6.2  | 891222953 | 80000001 | prefix     | 20  | 00:00:06 |
 | 6.6.6.2  | 891222954 | 80000002 | prefix     | 20  | 01:00:06 |
 | 6.6.6.1  | 0         | 80000003 | asExternal | 16  | 00:00:07 |
 | 6.6.6.2  | 0         | 80000006 | asExternal | 16  | 00:00:06 |
 | 6.6.6.1  | 1         | 80000001 | asExternal | 28  | 00:00:07 |
 | 6.6.6.2  | 1         | 80000003 | asExternal | 16  | 00:00:06 |
 | 6.6.6.2  | 2         | 80000001 | asExternal | 28  | 00:00:06 |
 | 6.6.6.1  | 0         | 80000001 | rtrInfo    | 16  | 00:00:07 |
 | 6.6.6.2  | 0         | 80000001 | rtrInfo    | 16  | 00:00:06 |
 |__________|___________|__________|____________|_____|__________|
r2#
r2#
1
2
3
4
5
6
7
8
r2#
r2#
r2#show ipv4 ospf 1 tre 0
r2#show ipv4 ospf 1 tre 0
`--r2
   `--r1
r2#
r2#
1
2
3
4
5
6
7
8
r2#
r2#
r2#show ipv6 ospf 1 tre 0
r2#show ipv6 ospf 1 tre 0
`--r2
   `--r1
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
r2#
r2#
r2#show ipv4 route v1
r2#show ipv4 route v1
 |~~~~~~|~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|
 | typ  | prefix      | metric | iface     | hop     | time     |
 |------|-------------|--------|-----------|---------|----------|
 | C    | 1.1.1.0/30  | 0/0    | ethernet1 | null    | 00:00:07 |
 | LOC  | 1.1.1.2/32  | 0/1    | ethernet1 | null    | 00:00:07 |
 | C    | 1.1.1.4/30  | 0/0    | ethernet2 | null    | 00:00:06 |
 | LOC  | 1.1.1.5/32  | 0/1    | ethernet2 | null    | 00:00:06 |
 | O E2 | 2.2.2.1/32  | 110/0  | ethernet1 | 1.1.1.1 | 00:00:03 |
 | C    | 2.2.2.2/32  | 0/0    | loopback1 | null    | 00:00:07 |
 | O E2 | 2.2.2.3/32  | 110/0  | ethernet2 | 1.1.1.6 | 00:00:03 |
 | O    | 2.2.2.33/32 | 110/20 | ethernet2 | 1.1.1.6 | 00:00:03 |
 |______|_____________|________|___________|_________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
r2#
r2#
r2#show ipv6 route v1
r2#show ipv6 route v1
 |~~~~~~|~~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|
 | typ  | prefix        | metric | iface     | hop       | time     |
 |------|---------------|--------|-----------|-----------|----------|
 | C    | 1234:1::/32   | 0/0    | ethernet1 | null      | 00:00:07 |
 | LOC  | 1234:1::2/128 | 0/1    | ethernet1 | null      | 00:00:07 |
 | C    | 1234:2::/32   | 0/0    | ethernet2 | null      | 00:00:07 |
 | LOC  | 1234:2::1/128 | 0/1    | ethernet2 | null      | 00:00:07 |
 | O E2 | 4321::1/128   | 110/0  | ethernet1 | 1234:1::1 | 00:00:03 |
 | C    | 4321::2/128   | 0/0    | loopback1 | null      | 00:00:07 |
 | O E2 | 4321::3/128   | 110/0  | ethernet2 | 1234:2::2 | 00:00:03 |
 | O    | 4321::33/128  | 110/20 | ethernet2 | 1234:2::2 | 00:00:03 |
 |______|_______________|________|___________|___________|__________|
r2#
r2#