Skip to content

Example: policy routing with nexthop

r1:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
hostname r1
buggy
!
logging file debug ../binTmp/zzz62r1-log.run
!
access-list a2b4
 sequence 10 permit all 2.2.2.101 255.255.255.255 all 2.2.2.201 255.255.255.255 all
 exit
!
access-list a2b6
 sequence 10 permit all 4321::101 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all 4321::201 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface loopback0
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.101 255.255.255.255
 ipv6 address 4321::101 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 pbr v1 sequence 10 a2b4 v1 nexthop 1.1.1.2
!
ipv6 pbr v1 sequence 10 a2b6 v1 nexthop 1234:1::2
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
hostname r2
buggy
!
logging file debug ../binTmp/zzz62r2-log.run
!
access-list a2b4
 sequence 10 permit all 2.2.2.101 255.255.255.255 all 2.2.2.201 255.255.255.255 all
 exit
!
access-list a2b6
 sequence 10 permit all 4321::101 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all 4321::201 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
 exit
!
access-list b2a4
 sequence 10 permit all 2.2.2.201 255.255.255.255 all 2.2.2.101 255.255.255.255 all
 exit
!
access-list b2a6
 sequence 10 permit all 4321::201 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all 4321::101 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 pbr v1 sequence 10 a2b4 v1 nexthop 1.1.1.5
ipv4 pbr v1 sequence 20 b2a4 v1 nexthop 1.1.1.1
!
ipv6 pbr v1 sequence 10 a2b6 v1 nexthop 1234:2::1
ipv6 pbr v1 sequence 20 b2a6 v1 nexthop 1234:1::1
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r3:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
hostname r3
buggy
!
logging file debug ../binTmp/zzz62r3-log.run
!
access-list b2a4
 sequence 10 permit all 2.2.2.201 255.255.255.255 all 2.2.2.101 255.255.255.255 all
 exit
!
access-list b2a6
 sequence 10 permit all 4321::201 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all 4321::101 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface loopback0
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.201 255.255.255.255
 ipv6 address 4321::201 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 pbr v1 sequence 10 b2a4 v1 nexthop 1.1.1.6
!
ipv6 pbr v1 sequence 10 b2a6 v1 nexthop 1234:2::2
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
r2#
r2#
r2#show ipv4 pbr v1
r2#show ipv4 pbr v1
 sequence 10 a2b4 v1 nexthop 1.1.1.5
  match=tx=0(0) rx=896(14) drp=0(0) accessed=00:00:00 ago, 00:00:00 timeout
 sequence 20 b2a4 v1 nexthop 1.1.1.1
  match=tx=0(0) rx=832(13) drp=0(0) accessed=00:00:00 ago, 00:00:00 timeout
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
r2#
r2#
r2#show ipv6 pbr v1
r2#show ipv6 pbr v1
 sequence 10 a2b6 v1 nexthop 1234:2::1
  match=tx=0(0) rx=640(10) drp=0(0) accessed=00:00:00 ago, 00:00:00 timeout
 sequence 20 b2a6 v1 nexthop 1234:1::1
  match=tx=0(0) rx=640(10) drp=0(0) accessed=00:00:00 ago, 00:00:00 timeout
r2#
r2#