Skip to content

Example: ebgp with nexthop tracking routemap

r1:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
hostname r1
buggy
!
logging file debug ../binTmp/zzz52r1-log.run
!
route-map rm1
 sequence 10 action permit
 sequence 10 match distance 0
 !
 exit
!
route-map rm2
 sequence 10 action permit
 sequence 10 set aspath 3 3 3
 !
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface loopback0
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.1 255.255.255.255
 ipv6 address 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
router bgp4 1
 vrf v1
 local-as 1
 router-id 4.4.4.1
 no safe-ebgp
 address-family unicast
 nexthop route-map rm1
 neighbor 1.1.1.2 remote-as 2
 no neighbor 1.1.1.2 description
 neighbor 1.1.1.2 local-as 1
 neighbor 1.1.1.2 address-family unicast
 neighbor 1.1.1.2 distance 20
 neighbor 1.1.1.2 route-map-in rm2
 neighbor 1.1.1.2 route-map-out rm2
 neighbor 1.1.1.6 remote-as 2
 no neighbor 1.1.1.6 description
 neighbor 1.1.1.6 local-as 1
 neighbor 1.1.1.6 address-family unicast
 neighbor 1.1.1.6 distance 20
 redistribute connected
 exit
!
router bgp6 1
 vrf v1
 local-as 1
 router-id 6.6.6.1
 no safe-ebgp
 address-family unicast
 nexthop route-map rm1
 neighbor 1234:1::2 remote-as 2
 no neighbor 1234:1::2 description
 neighbor 1234:1::2 local-as 1
 neighbor 1234:1::2 address-family unicast
 neighbor 1234:1::2 distance 20
 neighbor 1234:1::2 route-map-in rm2
 neighbor 1234:1::2 route-map-out rm2
 neighbor 1234:2::2 remote-as 2
 no neighbor 1234:2::2 description
 neighbor 1234:2::2 local-as 1
 neighbor 1234:2::2 address-family unicast
 neighbor 1234:2::2 distance 20
 redistribute connected
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
hostname r2
buggy
!
logging file debug ../binTmp/zzz52r2-log.run
!
route-map rm1
 sequence 10 action permit
 sequence 10 match distance 0
 !
 exit
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
interface loopback0
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.2 255.255.255.255
 ipv6 address 4321::2 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 no shutdown
 no log-link-change
 exit
!
router bgp4 1
 vrf v1
 local-as 2
 router-id 4.4.4.2
 no safe-ebgp
 address-family unicast
 nexthop route-map rm1
 neighbor 1.1.1.1 remote-as 1
 no neighbor 1.1.1.1 description
 neighbor 1.1.1.1 local-as 2
 neighbor 1.1.1.1 address-family unicast
 neighbor 1.1.1.1 distance 20
 neighbor 1.1.1.5 remote-as 1
 no neighbor 1.1.1.5 description
 neighbor 1.1.1.5 local-as 2
 neighbor 1.1.1.5 address-family unicast
 neighbor 1.1.1.5 distance 20
 redistribute connected
 exit
!
router bgp6 1
 vrf v1
 local-as 2
 router-id 6.6.6.2
 no safe-ebgp
 address-family unicast
 nexthop route-map rm1
 neighbor 1234:1::1 remote-as 1
 no neighbor 1234:1::1 description
 neighbor 1234:1::1 local-as 2
 neighbor 1234:1::1 address-family unicast
 neighbor 1234:1::1 distance 20
 neighbor 1234:2::1 remote-as 1
 no neighbor 1234:2::1 description
 neighbor 1234:2::1 local-as 2
 neighbor 1234:2::1 address-family unicast
 neighbor 1234:2::1 distance 20
 redistribute connected
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r1#
r1#
r1#show ipv4 bgp 1 sum
r1#show ipv4 bgp 1 sum
 |~~~~~~~~~~|~~~~|~~~~~~~|~~~~~~~|~~~~~~|~~~~~~~~~~|
 | neighbor | as | ready | learn | sent | uptime   |
 |----------|----|-------|-------|------|----------|
 | 1.1.1.2  | 2  | true  | 3     | 4    | 00:00:06 |
 | 1.1.1.6  | 2  | true  | 3     | 4    | 00:00:06 |
 |__________|____|_______|_______|______|__________|
r1#
r1#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r1#
r1#
r1#show ipv6 bgp 1 sum
r1#show ipv6 bgp 1 sum
 |~~~~~~~~~~~|~~~~|~~~~~~~|~~~~~~~|~~~~~~|~~~~~~~~~~|
 | neighbor  | as | ready | learn | sent | uptime   |
 |-----------|----|-------|-------|------|----------|
 | 1234:1::2 | 2  | true  | 3     | 4    | 00:00:07 |
 | 1234:2::2 | 2  | true  | 3     | 4    | 00:00:07 |
 |___________|____|_______|_______|______|__________|
r1#
r1#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r1#
r1#
r1#show ipv4 bgp 1 next
r1#show ipv4 bgp 1 next
 |~~~~~~~~~~|~~~~|~~~~~~~|~~~~~~~~~~|~~~~~|~~~~~~~~~~|
 | neighbor | as | reach | chg      | num | uptime   |
 |----------|----|-------|----------|-----|----------|
 | 1.1.1.2  | 2  | true  | 00:00:09 | 1   | 00:00:06 |
 | 1.1.1.6  | 2  | true  | 00:00:09 | 1   | 00:00:06 |
 |__________|____|_______|__________|_____|__________|
r1#
r1#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r1#
r1#
r1#show ipv6 bgp 1 next
r1#show ipv6 bgp 1 next
 |~~~~~~~~~~~|~~~~|~~~~~~~|~~~~~~~~~~|~~~~~|~~~~~~~~~~|
 | neighbor  | as | reach | chg      | num | uptime   |
 |-----------|----|-------|----------|-----|----------|
 | 1234:1::2 | 2  | true  | 00:00:08 | 1   | 00:00:07 |
 | 1234:2::2 | 2  | true  | 00:00:08 | 1   | 00:00:07 |
 |___________|____|_______|__________|_____|__________|
r1#
r1#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
r1#
r1#
r1#show ipv4 route v1
r1#show ipv4 route v1
 |~~~~~|~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|
 | typ | prefix     | metric | iface     | hop     | time     |
 |-----|------------|--------|-----------|---------|----------|
 | C   | 1.1.1.0/30 | 0/0    | ethernet1 | null    | 00:00:09 |
 | LOC | 1.1.1.1/32 | 0/1    | ethernet1 | null    | 00:00:09 |
 | C   | 1.1.1.4/30 | 0/0    | ethernet2 | null    | 00:00:09 |
 | LOC | 1.1.1.5/32 | 0/1    | ethernet2 | null    | 00:00:09 |
 | C   | 2.2.2.1/32 | 0/0    | loopback0 | null    | 00:00:09 |
 | B   | 2.2.2.2/32 | 20/0   | ethernet2 | 1.1.1.6 | 00:00:06 |
 |_____|____________|________|___________|_________|__________|
r1#
r1#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
r1#
r1#
r1#show ipv6 route v1
r1#show ipv6 route v1
 |~~~~~|~~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|
 | typ | prefix        | metric | iface     | hop       | time     |
 |-----|---------------|--------|-----------|-----------|----------|
 | C   | 1234:1::/32   | 0/0    | ethernet1 | null      | 00:00:10 |
 | LOC | 1234:1::1/128 | 0/1    | ethernet1 | null      | 00:00:10 |
 | C   | 1234:2::/32   | 0/0    | ethernet2 | null      | 00:00:09 |
 | LOC | 1234:2::1/128 | 0/1    | ethernet2 | null      | 00:00:09 |
 | C   | 4321::1/128   | 0/0    | loopback0 | null      | 00:00:10 |
 | B   | 4321::2/128   | 20/0   | ethernet2 | 1234:2::2 | 00:00:06 |
 |_____|_______________|________|___________|___________|__________|
r1#
r1#