1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285 | hostname r1
buggy
!
logging file debug ../binTmp/zzz30r1-log.run
!
route-policy p4
sequence 10 if network 9.9.2.11/32 ge 32 le 32
sequence 20 drop
sequence 30 enif
sequence 40 if network 9.9.3.11/32 ge 32 le 32
sequence 50 drop
sequence 60 enif
sequence 70 if network 9.9.4.11/32 ge 32 le 32
sequence 80 drop
sequence 90 enif
sequence 100 if network 0.0.0.0/0 ge 0 le 32
sequence 110 pass
sequence 120 enif
exit
!
route-policy p6
sequence 10 if network 9992::11/128 ge 128 le 128
sequence 20 drop
sequence 30 enif
sequence 40 if network 9993::11/128 ge 128 le 128
sequence 50 drop
sequence 60 enif
sequence 70 if network 9994::11/128 ge 128 le 128
sequence 80 drop
sequence 90 enif
sequence 100 if network ::/0 ge 0 le 128
sequence 110 pass
sequence 120 enif
exit
!
vrf definition tester
exit
!
vrf definition v1
rd 1:1
label-mode per-prefix
exit
!
vrf definition v2
rd 1:2
rt-import 1:2
rt-export 1:2
exit
!
vrf definition v3
rd 1:3
rt-import 1:3
rt-export 1:3
exit
!
vrf definition v4
rd 1:4
rt-import 1:4
rt-export 1:4
exit
!
interface loopback0
no description
vrf forwarding v1
ipv4 address 2.2.2.1 255.255.255.255
ipv6 address 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback21
no description
vrf forwarding v2
ipv4 address 9.9.2.1 255.255.255.255
ipv6 address 9992::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback22
no description
vrf forwarding v2
ipv4 address 9.9.2.11 255.255.255.255
ipv6 address 9992::11 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback23
no description
vrf forwarding v2
ipv4 address 9.9.2.111 255.255.255.255
ipv6 address 9992::111 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback31
no description
vrf forwarding v3
ipv4 address 9.9.3.1 255.255.255.255
ipv6 address 9993::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback32
no description
vrf forwarding v3
ipv4 address 9.9.3.11 255.255.255.255
ipv6 address 9993::11 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback33
no description
vrf forwarding v3
ipv4 address 9.9.3.111 255.255.255.255
ipv6 address 9993::111 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback41
no description
vrf forwarding v4
ipv4 address 9.9.4.1 255.255.255.255
ipv6 address 9994::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback42
no description
vrf forwarding v4
ipv4 address 9.9.4.11 255.255.255.255
ipv6 address 9994::11 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface loopback43
no description
vrf forwarding v4
ipv4 address 9.9.4.111 255.255.255.255
ipv6 address 9994::111 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
no shutdown
no log-link-change
exit
!
interface ethernet1
no description
vrf forwarding v1
ipv4 address 1.1.1.1 255.255.255.252
ipv6 address 1234:1::1 ffff:ffff::
mpls enable
mpls ldp4
mpls ldp6
no shutdown
no log-link-change
exit
!
router bgp4 1
vrf v1
local-as 1
router-id 4.4.4.1
no safe-ebgp
address-family ovpnuni
neighbor 2.2.2.2 remote-as 2
no neighbor 2.2.2.2 description
neighbor 2.2.2.2 local-as 1
neighbor 2.2.2.2 address-family ovpnuni
neighbor 2.2.2.2 distance 20
neighbor 2.2.2.2 update-source loopback0
neighbor 2.2.2.2 soft-reconfiguration
neighbor 2.2.2.2 send-community standard extended
neighbor 2.2.2.2 ovpn-route-policy-out p6
afi-ovrf v2 enable
afi-ovrf v2 redistribute connected
afi-ovrf v3 enable
afi-ovrf v3 redistribute connected
afi-ovrf v4 enable
afi-ovrf v4 redistribute connected
exit
!
router bgp6 1
vrf v1
local-as 1
router-id 6.6.6.1
no safe-ebgp
address-family ovpnuni
neighbor 4321::2 remote-as 2
no neighbor 4321::2 description
neighbor 4321::2 local-as 1
neighbor 4321::2 address-family ovpnuni
neighbor 4321::2 distance 20
neighbor 4321::2 update-source loopback0
neighbor 4321::2 soft-reconfiguration
neighbor 4321::2 send-community standard extended
neighbor 4321::2 ovpn-route-policy-out p4
afi-ovrf v2 enable
afi-ovrf v2 redistribute connected
afi-ovrf v3 enable
afi-ovrf v3 redistribute connected
afi-ovrf v4 enable
afi-ovrf v4 redistribute connected
exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ipv4 route v1 2.2.2.2 255.255.255.255 1.1.1.2
!
ipv6 route v1 4321::2 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff 1234:1::2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
security protocol telnet
no exec authorization
no login authentication
vrf tester
exit
!
!
end
|