Skip to content

Example: ospf with mpolka

r1:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
hostname r1
buggy
!
logging file debug ../binTmp/zzz22r1-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router ospf4 1
 vrf v1
 router-id 4.4.4.1
 traffeng-id 0.0.0.0
 segrout 10
 area 0 enable
 area 0 segrout
 redistribute connected
 exit
!
router ospf6 1
 vrf v1
 router-id 6.6.6.1
 traffeng-id ::
 segrout 10
 area 0 enable
 area 0 segrout
 redistribute connected
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.1 255.255.255.255
 ipv6 address 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf4 1 segrout index 1
 router ospf4 1 segrout node
 router ospf6 1 enable
 router ospf6 1 area 0
 router ospf6 1 segrout index 1
 router ospf6 1 segrout node
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.1 255.255.255.252
 ipv6 address 1234:1::1 ffff:ffff::
 mpolka enable 1 65536 10
 mpls enable
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf6 1 enable
 router ospf6 1 area 0
 no shutdown
 no log-link-change
 exit
!
interface tunnel1
 no description
 tunnel vrf v1
 tunnel source loopback1
 tunnel destination 2.2.2.3
 tunnel domain-name 2.2.2.2 2.2.2.3 , 2.2.2.3 2.2.2.3 ,
 tunnel mode mpolka
 vrf forwarding v1
 ipv4 address 3.3.3.1 255.255.255.252
 no shutdown
 no log-link-change
 exit
!
interface tunnel2
 no description
 tunnel vrf v1
 tunnel source loopback1
 tunnel destination 4321::3
 tunnel domain-name 4321::2 4321::3 , 4321::3 4321::3 ,
 tunnel mode mpolka
 vrf forwarding v1
 ipv6 address 3333::1 ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r2:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
hostname r2
buggy
!
logging file debug ../binTmp/zzz22r2-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router ospf4 1
 vrf v1
 router-id 4.4.4.2
 traffeng-id 0.0.0.0
 segrout 10
 area 0 enable
 area 0 segrout
 redistribute connected
 exit
!
router ospf6 1
 vrf v1
 router-id 6.6.6.2
 traffeng-id ::
 segrout 10
 area 0 enable
 area 0 segrout
 redistribute connected
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.2 255.255.255.255
 ipv6 address 4321::2 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf4 1 segrout index 2
 router ospf4 1 segrout node
 router ospf6 1 enable
 router ospf6 1 area 0
 router ospf6 1 segrout index 2
 router ospf6 1 segrout node
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.2 255.255.255.252
 ipv6 address 1234:1::2 ffff:ffff::
 mpolka enable 2 65536 10
 mpls enable
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf6 1 enable
 router ospf6 1 area 0
 no shutdown
 no log-link-change
 exit
!
interface ethernet2
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.5 255.255.255.252
 ipv6 address 1234:2::1 ffff:ffff::
 mpolka enable 2 65536 10
 mpls enable
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf6 1 enable
 router ospf6 1 area 0
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

r3:

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
hostname r3
buggy
!
logging file debug ../binTmp/zzz22r3-log.run
!
vrf definition tester
 exit
!
vrf definition v1
 rd 1:1
 exit
!
router ospf4 1
 vrf v1
 router-id 4.4.4.3
 traffeng-id 0.0.0.0
 segrout 10
 area 0 enable
 area 0 segrout
 redistribute connected
 exit
!
router ospf6 1
 vrf v1
 router-id 6.6.6.3
 traffeng-id ::
 segrout 10
 area 0 enable
 area 0 segrout
 redistribute connected
 exit
!
interface loopback1
 no description
 vrf forwarding v1
 ipv4 address 2.2.2.3 255.255.255.255
 ipv6 address 4321::3 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf4 1 segrout index 3
 router ospf4 1 segrout node
 router ospf6 1 enable
 router ospf6 1 area 0
 router ospf6 1 segrout index 3
 router ospf6 1 segrout node
 no shutdown
 no log-link-change
 exit
!
interface ethernet1
 no description
 vrf forwarding v1
 ipv4 address 1.1.1.6 255.255.255.252
 ipv6 address 1234:2::2 ffff:ffff::
 mpolka enable 3 65536 10
 mpls enable
 router ospf4 1 enable
 router ospf4 1 area 0
 router ospf6 1 enable
 router ospf6 1 area 0
 no shutdown
 no log-link-change
 exit
!
interface tunnel1
 no description
 tunnel vrf v1
 tunnel source loopback1
 tunnel destination 2.2.2.1
 tunnel domain-name 2.2.2.1 2.2.2.1 , 2.2.2.2 2.2.2.1 ,
 tunnel mode mpolka
 vrf forwarding v1
 ipv4 address 3.3.3.2 255.255.255.252
 no shutdown
 no log-link-change
 exit
!
interface tunnel2
 no description
 tunnel vrf v1
 tunnel source loopback1
 tunnel destination 4321::1
 tunnel domain-name 4321::1 4321::1 , 4321::2 4321::1 ,
 tunnel mode mpolka
 vrf forwarding v1
 ipv6 address 3333::2 ffff::
 no shutdown
 no log-link-change
 exit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
server telnet tester
 security protocol telnet
 no exec authorization
 no login authentication
 vrf tester
 exit
!
!
end

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r2#
r2#
r2#show ipv4 ospf 1 nei
r2#show ipv4 ospf 1 nei
 |~~~~~~~~~~~|~~~~~~|~~~~~~~~~|~~~~~~~~~~|~~~~~~~|~~~~~~~~~~|
 | interface | area | address | routerid | state | uptime   |
 |-----------|------|---------|----------|-------|----------|
 | ethernet1 | 0    | 1.1.1.1 | 4.4.4.1  | full  | 00:00:05 |
 | ethernet2 | 0    | 1.1.1.6 | 4.4.4.3  | full  | 00:00:05 |
 |___________|______|_________|__________|_______|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r2#
r2#
r2#show ipv6 ospf 1 nei
r2#show ipv6 ospf 1 nei
 |~~~~~~~~~~~|~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~|~~~~~~~~~~|
 | interface | area | address   | routerid | state | uptime   |
 |-----------|------|-----------|----------|-------|----------|
 | ethernet1 | 0    | 1234:1::1 | 6.6.6.1  | full  | 00:00:05 |
 | ethernet2 | 0    | 1234:2::2 | 6.6.6.3  | full  | 00:00:05 |
 |___________|______|___________|__________|_______|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
r2#
r2#
r2#show ipv4 ospf 1 dat 0
r2#show ipv4 ospf 1 dat 0
 |~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~~~~|~~~~~|~~~~~~~~~~|
 | routerid | lsaid   | sequence | type        | len | time     |
 |----------|---------|----------|-------------|-----|----------|
 | 4.4.4.1  | 4.4.4.1 | 80000005 | router      | 40  | 00:00:05 |
 | 4.4.4.2  | 4.4.4.2 | 80000007 | router      | 64  | 00:00:02 |
 | 4.4.4.3  | 4.4.4.3 | 80000005 | router      | 40  | 00:00:02 |
 | 4.4.4.1  | 0.0.0.0 | 80000002 | asExternal  | 16  | 01:00:05 |
 | 4.4.4.2  | 0.0.0.0 | 80000004 | asExternal  | 16  | 01:00:06 |
 | 4.4.4.3  | 0.0.0.0 | 80000002 | asExternal  | 16  | 01:00:05 |
 | 4.4.4.1  | 1.1.1.0 | 80000001 | asExternal  | 16  | 00:00:05 |
 | 4.4.4.2  | 1.1.1.0 | 80000001 | asExternal  | 16  | 00:00:06 |
 | 4.4.4.2  | 1.1.1.4 | 80000001 | asExternal  | 16  | 00:00:06 |
 | 4.4.4.3  | 1.1.1.4 | 80000001 | asExternal  | 16  | 00:00:05 |
 | 4.4.4.1  | 2.2.2.1 | 80000001 | asExternal  | 16  | 00:00:05 |
 | 4.4.4.2  | 2.2.2.2 | 80000001 | asExternal  | 16  | 00:00:06 |
 | 4.4.4.3  | 2.2.2.3 | 80000001 | asExternal  | 16  | 00:00:05 |
 | 4.4.4.1  | 3.3.3.0 | 80000001 | asExternal  | 16  | 00:00:01 |
 | 4.4.4.3  | 3.3.3.0 | 80000001 | asExternal  | 16  | 00:00:01 |
 | 4.4.4.1  | 4.0.0.0 | 80000002 | opaque-area | 40  | 00:00:05 |
 | 4.4.4.2  | 4.0.0.0 | 80000002 | opaque-area | 40  | 00:00:06 |
 | 4.4.4.3  | 4.0.0.0 | 80000002 | opaque-area | 40  | 00:00:05 |
 | 4.4.4.1  | 7.0.0.1 | 80000002 | opaque-area | 24  | 00:00:05 |
 | 4.4.4.2  | 7.0.0.1 | 80000002 | opaque-area | 24  | 00:00:06 |
 | 4.4.4.3  | 7.0.0.1 | 80000002 | opaque-area | 24  | 00:00:05 |
 | 4.4.4.1  | 8.0.0.1 | 80000001 | opaque-area | 36  | 00:00:05 |
 | 4.4.4.2  | 8.0.0.1 | 80000001 | opaque-area | 36  | 00:00:05 |
 | 4.4.4.3  | 8.0.0.1 | 80000001 | opaque-area | 36  | 00:00:02 |
 | 4.4.4.2  | 8.0.0.2 | 80000001 | opaque-area | 36  | 00:00:02 |
 |__________|_________|__________|_____________|_____|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
r2#
r2#
r2#show ipv6 ospf 1 dat 0
r2#show ipv6 ospf 1 dat 0
 |~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|~~~~~~~~~~~~|~~~~~|~~~~~~~~~~|
 | routerid | lsaid     | sequence | type       | len | time     |
 |----------|-----------|----------|------------|-----|----------|
 | 6.6.6.1  | 200825363 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.1  | 200825364 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.2  | 673275765 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.2  | 673275766 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.2  | 673275767 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.3  | 931425700 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.3  | 931425701 | 80000001 | link       | 24  | 00:00:06 |
 | 6.6.6.1  | 0         | 80000003 | router     | 20  | 00:00:06 |
 | 6.6.6.2  | 0         | 80000004 | router     | 36  | 00:00:03 |
 | 6.6.6.3  | 0         | 80000003 | router     | 20  | 00:00:03 |
 | 6.6.6.1  | 200825363 | 80000001 | prefix     | 32  | 00:00:06 |
 | 6.6.6.1  | 200825364 | 80000001 | prefix     | 20  | 00:00:06 |
 | 6.6.6.2  | 673275765 | 80000001 | prefix     | 32  | 00:00:06 |
 | 6.6.6.2  | 673275766 | 80000001 | prefix     | 20  | 00:00:06 |
 | 6.6.6.2  | 673275767 | 80000001 | prefix     | 20  | 00:00:06 |
 | 6.6.6.3  | 931425700 | 80000001 | prefix     | 32  | 00:00:06 |
 | 6.6.6.3  | 931425701 | 80000001 | prefix     | 20  | 00:00:06 |
 | 6.6.6.1  | 0         | 80000003 | asExternal | 16  | 00:00:06 |
 | 6.6.6.2  | 0         | 80000005 | asExternal | 16  | 00:00:06 |
 | 6.6.6.3  | 0         | 80000003 | asExternal | 16  | 00:00:06 |
 | 6.6.6.1  | 1         | 80000002 | asExternal | 16  | 00:00:01 |
 | 6.6.6.2  | 1         | 80000003 | asExternal | 16  | 00:00:06 |
 | 6.6.6.3  | 1         | 80000004 | asExternal | 16  | 00:00:01 |
 | 6.6.6.1  | 2         | 80000001 | asExternal | 28  | 00:00:01 |
 | 6.6.6.2  | 2         | 80000001 | asExternal | 28  | 00:00:06 |
 | 6.6.6.3  | 2         | 80000003 | asExternal | 28  | 00:00:01 |
 | 6.6.6.1  | 0         | 80000002 | rtrInfo    | 40  | 00:00:06 |
 | 6.6.6.2  | 0         | 80000002 | rtrInfo    | 40  | 00:00:06 |
 | 6.6.6.3  | 0         | 80000002 | rtrInfo    | 40  | 00:00:06 |
 | 6.6.6.1  | 0         | 80000003 | ext-router | 36  | 00:00:06 |
 | 6.6.6.2  | 0         | 80000004 | ext-router | 68  | 00:00:03 |
 | 6.6.6.3  | 0         | 80000003 | ext-router | 36  | 00:00:03 |
 | 6.6.6.1  | 1         | 80000002 | ext-prefix | 52  | 00:00:06 |
 | 6.6.6.2  | 1         | 80000002 | ext-prefix | 52  | 00:00:06 |
 | 6.6.6.3  | 1         | 80000002 | ext-prefix | 52  | 00:00:06 |
 |__________|___________|__________|____________|_____|__________|
r2#
r2#
1
2
3
4
5
6
7
8
9
r2#
r2#
r2#show ipv4 ospf 1 tre 0
r2#show ipv4 ospf 1 tre 0
`--r2
  |`--r1
   `--r3
r2#
r2#
1
2
3
4
5
6
7
8
9
r2#
r2#
r2#show ipv6 ospf 1 tre 0
r2#show ipv6 ospf 1 tre 0
`--r2
  |`--r1
   `--r3
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
r2#
r2#
r2#show ipv4 route v1
r2#show ipv4 route v1
 |~~~~~~|~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~|~~~~~~~~~~|
 | typ  | prefix     | metric | iface     | hop     | time     |
 |------|------------|--------|-----------|---------|----------|
 | C    | 1.1.1.0/30 | 0/0    | ethernet1 | null    | 00:00:07 |
 | LOC  | 1.1.1.2/32 | 0/1    | ethernet1 | null    | 00:00:07 |
 | C    | 1.1.1.4/30 | 0/0    | ethernet2 | null    | 00:00:07 |
 | LOC  | 1.1.1.5/32 | 0/1    | ethernet2 | null    | 00:00:07 |
 | O    | 2.2.2.1/32 | 110/20 | ethernet1 | 1.1.1.1 | 00:00:06 |
 | C    | 2.2.2.2/32 | 0/0    | loopback1 | null    | 00:00:07 |
 | O    | 2.2.2.3/32 | 110/20 | ethernet2 | 1.1.1.6 | 00:00:03 |
 | O E2 | 3.3.3.0/30 | 110/0  | ethernet2 | 1.1.1.6 | 00:00:01 |
 |______|____________|________|___________|_________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
r2#
r2#
r2#show ipv6 route v1
r2#show ipv6 route v1
 |~~~~~~|~~~~~~~~~~~~~~~|~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~~|~~~~~~~~~~|
 | typ  | prefix        | metric | iface     | hop       | time     |
 |------|---------------|--------|-----------|-----------|----------|
 | C    | 1234:1::/32   | 0/0    | ethernet1 | null      | 00:00:07 |
 | LOC  | 1234:1::2/128 | 0/1    | ethernet1 | null      | 00:00:07 |
 | C    | 1234:2::/32   | 0/0    | ethernet2 | null      | 00:00:07 |
 | LOC  | 1234:2::1/128 | 0/1    | ethernet2 | null      | 00:00:07 |
 | O E2 | 3333::/16     | 110/0  | ethernet1 | 1234:1::1 | 00:00:02 |
 | O    | 4321::1/128   | 110/20 | ethernet1 | 1234:1::1 | 00:00:06 |
 | C    | 4321::2/128   | 0/0    | loopback1 | null      | 00:00:07 |
 | O    | 4321::3/128   | 110/20 | ethernet2 | 1234:2::2 | 00:00:03 |
 |______|_______________|________|___________|___________|__________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r2#
r2#
r2#show ipv4 segrou v1
r2#show ipv4 segrou v1
 |~~~~~~~~~~~~|~~~~~~~|~~~~~~~~|~~~~~~~~~|
 | prefix     | index | base   | oldbase |
 |------------|-------|--------|---------|
 | 2.2.2.1/32 | 1     | 137496 | 137496  |
 | 2.2.2.3/32 | 3     | 855837 | 855837  |
 |____________|_______|________|_________|
r2#
r2#
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
r2#
r2#
r2#show ipv6 segrou v1
r2#show ipv6 segrou v1
 |~~~~~~~~~~~~~|~~~~~~~|~~~~~~~~|~~~~~~~~~|
 | prefix      | index | base   | oldbase |
 |-------------|-------|--------|---------|
 | 4321::1/128 | 1     | 756027 | 756027  |
 | 4321::3/128 | 3     | 986166 | 986166  |
 |_____________|_______|________|_________|
r2#
r2#